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Scope and Introduction 

This document provides an outline design, specifications and user manual for the Plessey 

Data-Vμ™ microLED Evaluation Kit PD01000. The kit contains a microLED display with driver 

and control board. 

 

Description 

The Plessey Data-Vμ™ microLED Evaluation Kit contains components for the user to 

evaluate the Plessey Data-Vμ™ microLED display. The kit can be used standalone to 

demonstrate the intensity of the display, or with a computer to evaluate the display 

technology in more depth. The display can be integrated into existing optical systems to 

evaluate the benefits of Plessey’s Data-Vμ™ microLED displays. 

 

 

 

 

 

Related Documents and Specifications 

296141 - PD01xxx - Data-Vμ™ microLED Chip Advance Product Datasheet 
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Evaluation Kit Contents 

The PD01000 evaluation kit consists the following (contained within a card box): 

• PD01001 (driver board assembly) 

• PD01002 (green display module) 

• Base module board 

• Bluetooth Module (HC-06) 

• USB battery 

• USB Type-A to Micro-B Cable 

• USB Memory Stick 

• Printed Quick Start Guide

The PD01001 Driver and Connector set consists of the component populated driver board, 

assembled to the display (PD01002) using a Samtec interposer connector board using 

screws and alignment pins. The PD01002 display is a PPS4138 green display with normal 

orientation on an FR4 board. The driver board is supplied with Data-Vμ™ firmware which 

allows a command line interface over UART/USB. 

The PD01001 and PD01002 are supplied assembled, plugged into the PPS4144 base module 

(which can be powered by the supplied USB). 

Safety and Safe Operation 

Operating the display on high brightness settings can cause eye damage.  When increasing 

the brightness do not look directly at the light source.  Do not stare at the light source.  

Direct the display away from the eyes, e.g. toward a piece of card. 
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Driver Board 

Description 

Refer to Appendix A for the driver board schematic. The driver board is based around an 

ATMega328 microcontroller and is compatible with the Arduino Integrated Design 

Environment (IDE). The driver generates a programmable voltage source for the common 

anode of the Data-Vμ™ microLED display. 

The driver board voltage source is generated from the ATMega328 and is buffered through 

an Op-Amp, NMOS voltage follower and can be programmed anywhere between 0V to VDD 

(norm 5V). 

The symbols can then be individually turned on by switching an NMOS to ground. There is 

an array of 42 dual NMOS transistors to allow up to 84 symbols to be dimmed 

independently. The gates of the NMOS array is controlled by two LT8500 PWM chips. These 

chips have 48 individually controllable PWM channels with 12 bit resolution. The PWM is 

supplied a 2MHz clock generated by the ATMega328, resulting in a PWM frequency of 

2MHz/4095 = 488Hz. 

The LT8500 ICs also allow a duty cycle correction to be applied to each channel. This is a 6 

bit correction which allows a duty cycle variation of 0.5x – 1.5x. Refer to the LT8500 

datasheet for more information on calculating the calibration values 

(https://www.analog.com/media/en/technical-documentation/data-sheets/LT8500.pdf) 

The ATMega328 can be connected by UART over USB using the driver board’s FTDI chip. 

Reprogramming over USB is supported by the bootloader present on the ATMega328. Only 

one UART port is present on the ATMega328 and is shared by direct UART connection and 

via the FTDI for USB connection; communicate by UART or USB, the ATMega328 cannot 

communicate with both simultaneously. 

To measure the current of the display measure the voltage drop across R14, the 1 Ohm (+/-

0.25%) current sense resistor. This can be accessed from the VDEV, VCOM pins. The display 

can be driven with an external power supply if required – connect an external power supply 

to VCOM and de-solder the current sense resistor R14. The current sense resistor may be 

bypassed using a zero Ohm resistor in R14 position or by shorting resistor R13. 

The driver board is connected to the display using a Samtec Z-Ray. This consists of an 

interposer and a pair of screws and alignment pins. 
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Mechanical Specification 

 

 

Electrical Specification 

 

Parameter Minimum Typical Maximum Units 

Supply Voltage  5.0 5.25 Volts 

Supply Current   (TBC) Amps 

Current per 

channel 

  (TBC) Amps 

Microcontroller 

operating 

frequency 

 8  MHz 

Channel PWM 

frequency 

 2  MHz 

Channel PWM 

resolution 

 12  bits 

Number of 

channels 

 84   
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Mother/base Board Specifications 

The USB battery is supplied partly charged, it is advised to fully charge prior to use. When 

charged, insert the battery’s USB Micro-B plug into the base module. Do not connect to the 

driver board USB when the battery is in use. 

 

Electrical Specification 

 

Parameter Minimum Typical Maximum Units 

Supply Voltage  5.0 5.25 Volts 

Supply Current    Amps 

Battery 

Capacity 

 3  Ah 

Battery Charge 

Current (USB) 

 1  Amps 

Battery Charge 

Time 

 4  Hours 
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Display Board Specifications 

Refer to display PD01xxx Data-Vμ™ microLED Chip Advance Product Datasheet for full 

information. 

Mechanical Specification 

 

Electrical Specification PD01002 

 

Parameter Minimum Typical Maximum Units 

Forward 

Voltage 

  3 Volts 

Dominant 

Wavelength 

500  555 nm 

Current per 

channel 

   Amps 

Number of 

segments 

 61   
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Connection and Control Options 

Driver Board Block Diagram 

 

 

 

Electrical Connection Detail 

The driver board connections consist of a microUSB socket and 17 pins on a 0.1” pitch, 

connections and major components shown below. 

 

Pin Function 

RESET Device reset (active HIGH?) – TTL levels 

SCK SPI connection clock – TTL levels 
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MOSI SPI data input (Master Output Slave Input) – TTL levels 

MISO SPI data output (Master Input Slave Output) – TTL levels 

GND Ground connection (0V) 

VCC Supply Voltage (+5V) – do not connect if microUSB providing power 

Tx UART transmit (data from driver board) – TTL levels 

Rx UART receive (data to driver board) – TTL levels 

SDA I2C data – TTL levels 

SCL I2C clock – TTL levels 

GPIOx General Purpose I/O to microcontroller, or button inputs – TTL levels 

GND Ground connection (0V) 

VDEV LED drive voltage – high side of current sense resistor 

COM LED common – anode of display (can be used to power display by 

removing R14) 
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Control, Command Set and Programming Options 

 

Button Control 

Slide the ‘battery’ switch from Battery OFF to Battery ON. The four buttons on the base 

module can then be used to demonstrate the display, buttons functions as follows: 

Button Number Button Function 

1 Switch all segments on (drive voltage 2.7V) or off 

2 Counter demo – press to initiate to 0000, press/hold to increment 

3 Decrease display brightness 

4 Increase display brightness 

Press and release button 1 and the display will illuminate (all segments) at a low level (2.7V 

drive, PWM value of 1). Press and release button 4 to increase brightness (PWM changed) - 

9 presses to maximum brightness. Press and release button 3 to decrease brightness (PWM 

changed) - 9 presses to minimum brightness. Ensure display is angled away from eyes 

when brightness increased. 

Button 2 initiates a displayed counter demonstration. With display on and brightness set 

(using button 1, 3 and 4), press and release button 2 to set counter to 0000. Press and 

release to increase counter by 1, press and hold to rapidly increase counter to 9999 and 

loops to 0000. Pressing button 3 or 4 will increase or decrease brightness (unless at 

maximum or minimum brightness respectively) and display all segments, press button 2 to 

return to the counter display. 

Serial Connection – UART & USB 

The driver board can be accessed using a direct UART connection, or via a USB connection. 

Do not connect to the UART when USB is active. 

To connect via USB, insert the supplied cable’s USB Micro-B plug into the driver board 

module USB socket and connect the USB Type-A plug to a suitable PC’s USB socket. The 

driver board will instantiate as a serial port, communication should be made to this serial 

port using PuTTY or similar command-line – 9600 baud, 8 data bits, 1 stop bit, no parity. 

Once a serial connection is established to the driver board, the driver board will respond 

with a text line “*******DataVu Driver CLI******” and a prompt “>”. 
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Command Arguments Function 

h   

Help, returns list of commands. 
help 

c <Cal_1> <Cal_2> 

<Cal_3> 

… 

<Cal_n> 

Updates the calibration data. Here n is the number 

of symbols on the display. Each symbol can have a 

unique PWM weightings which allow for display 

non-uniformity to be corrected for. Each symbol can 

be corrected by a weighting of 0.5x to 1.5x with six 

bit resolution. This calibration data will be saved to 

the EEPROM on the ATMega and reloaded when the 

driver is power cycled. 

cOn  
Turns the calibration feature on. The write frame 

command will need to be run after to see the 

effects. 

cOff  
Turns the calibration feature off. The write frame 

command will need to be run after to see the 

effects. 

u <Value1> <Value2> 

… 

<Value n> 

Updates all values in the software frame buffer. This 

will reset all the values in the software frame buffer 

with the specified value, an eight bit (integer, 0-255) 

PWM value for all the symbols. 

ua <Value> Updates all values in the software frame buffer. This 

will reset all the values in the software frame buffer 

with the specified value, an eight bit (integer, 0-255) 

PWM value for all the symbols 

ud <C> <Digit> <Value>  Updates a seven segment element in the software 

frame buffer. C - the character to show on the seven 

segment element (0-9, A-F). Digit - the digit number 

specifies which seven segment element to update. 

Value - the eight bit (integer, 0-255) PWM value for 

the seven segment element. 

us <Symbol> <Value> 
Updates a single symbol's, an eight bit (integer, 0-

255) PWM value in the software frame buffer. 

v <Voltage> 
Sets the LED anode voltage. The voltage can be set 

between 0.0 and 5.0 (volts). The DAC has eight bit 

resolution which equates to a voltage resolution of 

20mV. The specified voltage may not match the 

output voltage exactly. The output voltage depend 

on the board voltage which the firmware assumes to 

be 5V. For an accurate voltage a direct measurement 

on the driver board is needed. 
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w  
Writes the software frame buffer to the display. This 

needs to be run to any of the frame buffer updates 

in the previous commands. 

 

 

Some programming examples and advisories: 

• To display all segments at low intensity, type “v 2.5” (without quotes, this sets the 

display voltage to 2.5V) and press return, follow this by “ua 10” and “w” (similarly 

without quotes, and press return each time. This sets all segments to 10/255 PWM 

and updates the display. 

• To turn all segments off, either set voltage to 0 “v 0” or turn all segments off “ua 0” 

following by “w”. 

• To display FE in two 7-segments at low intensity, type “v 2.5” (without quotes, this 

sets the display voltage to 2.5V) and press return, follow this by “ud E 0 10” “ud F 1 

10” and “w” (similarly without quotes, and press return each time). 

• Voltage range is 0-5V, usable range is 2.2 (very dim) to 2.8. Higher than 2.8V will 

result in varied segment brightness depending on how many segments are 

illuminated as drive voltage is dropped across the current sense resistor. TBA 

• Command 8-bit PWM value (0-255) is converted to internal 12-bit PWM value (0-

4095). 

Programming using the Arduino Integrated Design Environment 

The driver board features an ATMEGA328 microcontroller which contains Data-Vμ™ 

firmware. The firmware is available for download and modification. Download the 

Arduino Integrated Development Environment from the Arduino website (1.6.4 or 

later is required): 

www.arduino.cc 

Follow instructions to install the IDE. Once installed, connect the driver board to the PC – 

on a Windows PC check the Devices and Printers for a “FT232R USB UART” device and 

note the COM port number. 

• Open the Arduino IDE. 

• In File->Preferences menu, enter the following into the (initially blank for a new IDE 

install) Additional Boards Manager URLs field: 

https://raw.githubusercontent.com/Plessey/DataVuBoard/master/package_DataVuBoard_i

ndex.json 



Page 14 of 24 

Document number 296194 Version 2 
   24th January 2020 

 

• In Tools->Board:->Boards Manager... menu, scroll down to the “DataVu by Plessey” 

board and click the Install button, then close the Boards Manager. 

 

 

• Now select the DataVu driver board in Tools->Board: When correctly selected, menu 

should read Board:”DataVu_Driver” menu. In Tools->Display: (defaults to 

NO_DISPLAY) select PD01002/4/6/8 for this PD01000 Evaluation Kit with normal 

orientation display. Display type PD01003/5/7/9 is for laterally inverted display. In 

Tools->Port: set the port number (noted above, example shown below is COM241). 
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• Once the DataVu driver board has been instantiated, you will need to install the 

DataVuLib from Github. Create a ZIP file by clicking the Clone or download button on 

the webpage below, then Download ZIP. 

https://github.com/Plessey/DataVuLib 

• In the Arduino IDE Sketch->Include Library menu select Add ZIP Library… and select 

the ZIP file created above. 

 

• The DataVuLib provides two examples. In the Arduine IDE File->Examples-

>DataVuLib-master menu: 

o DataVuFW – the default code allowing serial access via USB 

o Counter – an example counter 
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• If the IDE Serial Monitor is used, ensure the enter character is Carriage return rather 

than default Newline. 
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Segment driver address mapping 

 

Arrows and Symbols 

Symbol 
Symbol  

id 

Symbol 

Description 
Address Emitting Area (sq um) 

 A01 Go Straight 0 251800 

 A02 Turn left 1 218200 

 A03 Turn right 2 218200 

 A04 U-turn 3 200400 

 S01 Door open 49 72815 

 S02 Fuel pump 50 63956 
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S03 

kilometres 

per hour 
51 29391 

 S04 yards 52 15877 

 S05 metres 53 9845 

 
S06 

milli- 

Watts 
54 22310 

 
S07 

degrees 

Celsius 
55 13052 

 S08 AM 56 10409 

 S09 PM 57 9666 

 
S10 

degrees 

Fahrenheit 
58 12240 

 
S11 

miles per 

hour 
59 25584 

 
S12 

Plessey 

logo 
60 66934 

 

Large 7-segment characters and dots 

Symbol 
Symbol  

id 

Addres

s 

Emitting 

Area  

(sq um) 

 

Symbol 
Symbol  

id 

Addres

s 

Emitting 

Area  

(sq um) 

 N0A 4 51106  
 N2A 18 51106 

 N0B 5 51106   N2B 19 51106 

 N0C 6 51106  
 N2C 20 51106 

 N0D 7 51106  
 N2D 21 51106 
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 N0E 8 51106  
 N2E 22 51106 

 N0F 9 51106  
 N2F 23 51106 

 N0G 10 51106  
 N2G 24 51106 

 N1A 11 51106  
 N3A 25 51106 

 N1B 12 51106  
 N3B 26 51106 

 N1C 13 51106  
 N3C 27 51106 

 N1D 14 51106   N3D 28 51106 

 N1E 15 51106   N3E 29 51106 

 N1F 16 51106   N3F 30 51106 

 N1G 17 51106  
 N3G 31 51106 

     
 D01 46 20105 

     
 D02 47 20105 

     
 D03 48 20105 
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Small 7-segment characters and dots 

 

 

  

Symbol 
Symbol  

id 
Address Emitting Area (sq um) 

 N4A 32 13357 

 N4B 33 13357 

 N4C 34 13357 

 N4D 35 13357 

 N4E 36 13357 

 N4F 37 13357 

 N4G 38 13357 

 N5A 39 13357 

 N5B 40 13357 

 N5C 41 13357 

 N5D 42 13357 

 N5E 43 13357 

 N5F 44 13357 

 N5G 45 13357 
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Appendix A - Driver PCB Schematics 
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Appendix B - Handling and Safety Instructions 

The devices must not be operated in reverse bias. 

There is no ESD protection on individual symbol channels so all precautions for handling 

electrostatic sensitive devices must be observed. 

 

Operating the display on high brightness settings can cause eye damage.  When increasing 

the brightness do not look directly at the light source.  Do not stare at the light source.  

Direct the display away from the eyes, e.g. toward a piece of card. 

 

 

Contact 

Plessey Semiconductors Ltd | Plymouth| Tamerton Road, Roborough |Plymouth, Devon| 

PL6 7BQ, UK 

microLEDs@plesseysemi.com | +44 1752 693000 | www.plesseysemi.com 

 


